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Eltek TU1114 – User Instructions for RC250 receiver 

Packed Items 

RC250 receiver with serial and Modbus output 
Antenna (basic whip) – Eltek type UHFFlexi/SMA 
MP12U power supply with regional adaptor 
LC68 – RC250 to PC serial lead 
LCTX3 – Transmitter to PC serial lead 
USB to serial converter lead 

RxConfiguration software 

RxConfig can also be downloaded from 
www.eltekdataloggers.co.uk. When installed, RxConfiguration 
creates a folder “Eltek”. In this folder are the RC250 documents 
for details of Modbus over serial, etc. for Modbus limitations. 

The program allows the user to: 

Read transmitter settings 
Set the transmitter interval 
Associate an RC250 Channel with a specific 
transmitter channel 
Meter configured RC250 channels. 

Operation 
The RC250 works by first receiving a data packet from a transmitter, verifying then 

storing the data to be read by the external device or PC. Data is verified by means of 

a checksum contained in the message and the associated transmitter number. If the 

RC250 does not receive a message from a transmitter within a configured time, the 

stored value will be set to “no data”. For more detail see page 5 “No Data interval”. 

Example application: Typically, data from the RC250 to the PC is updated every 30 

minutes, so the transmitter interval is set to 5 minutes (that is PC update period ÷ 6) 

and the “No Data” interval to 2 hours. (i.e. PC update period x 4). If the transmitter 

stops transmitting for any reason the PC should register this fact after 2 hours. 

Power Requirements 
The RC250 requires permanent AC mains connection. Use only the AC power supply 

type MP12U. Built-in Ni-Mh batteries provide up to 3 days standby in the event of 

power failure. A fully discharged battery is charged in 72 hours. Once the batteries 

become low the RC250 will switch itself into a low power mode and turn off the 

receiver. OFF will appear in the display. 
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Note: the RC250 is despatched in the OFF mode. The RC250 will power up (turn on) 

next time external power is applied. The display will then switch to working mode. 

The RC250 can be turned off by removing the external power and then from the 

RxConfiguration menu select Tools >Turn Receiver Off. Alternatively, briefly press 

the concealed switch accessed through the rear of the case.  

Application 
For users who wish to use the Eltek GenII series of transmitters with third party or 

proprietary software. The RC250 can also be used to interface GenII transmitters to a 

BMS or existing data acquisition systems using Modbus. 

Locating the RC250 
The RC250 and antenna should be located in a position clear of interference, in 

particular that generated by computers and monitors, and away from surfaces that 

can compromise RF performance e.g. steel or damp or reinforced walls. Use of the 

optional dipole antenna will maximise coverage. 

LED Indicator 
A red LED on the top of the RC250 Indicates the receiver has successfully received a 

valid data packet.  

RC250 programming leads 
• LC68 – used to program the RC250 from the PC serial port or via the USB 

adaptor if no serial port is available.  

• LCTX3 – used to program the Transmitter from the PC serial port or via the 
USB adaptor if no serial port is available. 

A single serial port on the PC can be used but this will mean having to change over 

the LCTX3 lead and LC68 as required. Note, in File > Properties the PC COM port 

can be nominated. Use Windows Device Manager to list the COM ports available on 

your computer. Type Device Manager in the Windows search box to open this and 

look for the section “Ports (COM & LPT)”. USB to serial converters supplied by Eltek 

are listed as Prolific USB-to-Serial Comm Port.  
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Using RxConfiguration Software 
Load the program on your PC – it will try to find an existing “Eltek” program folder. 
To configure the RC250 use the LC68 lead. Connect one end to the serial port of the 
PC and the other to the mini DIN socket situated on the top panel of the RC250. Set 

the COM port using the menu option File > Properties. The full menu options are 
described below; 

Menu: 
File  Load Receiver  Upload an existing RC250 configuration 

File  Save  Receiver Save the current RC250 
configuration 

File  Properties  Select PC serial port for communications 
with RC250 and Transmitter 

Tools  Turn Receiver off  Turns receiver off (display indicated OFF) 

Tools  ModBus Setup  Sets device (node) address and register 
addresses for ModBus communications. See 
ModBus Configuration section. 

Buttons: in the TX configuration table 

Get TX Get the current configuration from the 
Transmitter 

Set Interval  
 

Set TX Interval (use the drop down menu) 

Set Sensor On Time  Applicable only to transmitter where the 
external sensor needs power before a 
reading can be taken. E.g. GS42/GS44 and 
GD43 

Buttons: in the RX configuration table  

Get RX  Get the current configuration from the 
RC250 

Set RX  Set the configuration in the RC250 

Start Meter / Stop Meter  Load table with received data 

Edit Chan  Click over a channel, click Edit Channel to 
edit. (Use to accept a transmitter not 
available for direct connection.) 

Clear Chan data  Click over a channel, click Clear Channel 
data 

Set Nbr Chans  
 

Enter Number of channels to display (160 

maximum) and click Set Nbr Chans to 
confirm (this reduces unnecessary on screen 
information and speeds up the interface). 
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Channel Set-up Procedure 
Transmitter present: 

1. Start up the RxConfiguration program. (If this is the first time it has run you 

will need to configure the serial port(s) using File > Properties.) 
2. Connect the PC to the RC250 using the LC68 programming lead (and USB 

converter if required) 

3. Get the current or start a new RC250 configuration using the Get RX 
button (you should see the details appear in the right hand list box). 

4. Now connect each transmitter to the PC using an LC-TX3* programming 
lead. 

5. Use File > Properties to set the TX serial port. 

6. Get the transmitter details using the Get TX button (the TX serial number 
will appear) 

7. Set the transmitter interval. This should be about one sixth of the update 
interval required in the PC (or connected monitoring device) 

8. Click on a channel, click Select Range, and choose input type from drop 

down. Click OK to confirm. 
9. Repeat for channels applicable to connected TX 
10. Return to step 4 to add additional transmitters 
11. Connect the PC to the RC250 using the LC68 programming lead 
12. Select the destination RC250 channel (by single clicking and highlighting it) 
13. Select the required transmitter channel (by single clicking and highlighting 

it). 
14. Copy the channel details to the RC250 configuration using the >> button. 

Note RxConfig will assume the next TX channel and next RX channel are to 
be linked. Click the >> button to confirm or set up as required. 

15. Copy the configuration to the RC250 using the Set RX button. 

* To gain access to the transmitter programming socket the bottom cover must be 
removed (2 x pozi-drive screws). Carefully remove the battery pack but do not 
disconnect it. The programming socket is a 3.5mm stereo jack socket that will now 
be accessible. 

Using pulse count transmitters 
Pulse count transmitters use an internal counter which counts from 0 to 65535 and 
is incremented each time a pulse is measured. The counter rolls over when it reaches 
65535. Transmitters will send the current value of their internal counter each time 
they transmit. It is therefore necessary to perform a calculation in the receiving 
software / device which subtracts the previously received pulse counter value from 
the current one, giving the number of pulses counted. 

  



Page 5 of 10 
 

Columns in the RX Configuration panel table: 
Chan  RC250 channel (maximum 160 channels) 

Tx Serial  Tx serial number 

Tx Chan  TX channel (alpha character A to H) 

Tx Range  TX channel range e.g. Humidity SHT if the B channel of a GD10 (see 
Page 9 for an example of the Edit Rx Channel pane) 

Value  Tx value of the last valid data received expressed in units allocated to 
the range. These can be default or configured as engineering units. 

Batt  Tx battery condition expressed in % 

Age  Time, in seconds, since the last valid reading received. Age will not be 
normally greater than 2 times the transmission interval. If it is, there 
may be permanent or temporary loss of communications and should 
be investigated. 

Nbr TX  Number of successful transmissions received, indicates the reliability of 
performance and is for comparison purposes only. 

 

No Data Interval 
Within the Edit RX Channel window is the feature No data Interval. The RC250 

expects new channel information from the transmitter on a frequent basis to refresh 
the last valid value held in a buffer. If data is not received within a configurable 

period, e.g., due to transmitter failure, the value is reported as No Data. This in turn 
can be processed as appropriate to the application by the connected software. The 
No data Interval will default to the TX interval x 6 and can be set (as hh:mm:ss) for 
special applications on a per channel basis.  

Modbus configuration 
The ModBus Setup menu (Tools > Modbus setup) allows the user to configure the 
ModBus device address and the holding register addresses for the various 

parameters. Node Address should be set to the required device identifier. The 
following ten boxes are for specifying the device identifier and start address of 
holding registers for reporting the transmitter information. The value in each of these 
boxes must be greater than that in the previous box. The difference must be greater 
than the number of channels configured in the RC250. 
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N.B. serial numbers below 43282 (showing in RxConfig as Version 2.7 or below) will 
not display or contain valid data for the last 3 registers: RSSI Address, Ext Voltage 
Address or Battery Voltage Address. These values are only available in RC250 
firmware version 2.8 and greater. 

When reading the values from the RC250, the only Function Code that can be used 
is 'Read Holding Registers' (0x03). It is possible to read several registers at a time 
using the Quantity of Registers field, but note that RC250 is limited to 50 registers at 
a time. 

The address values used in the RC250 protocol are the actual addresses encoded in 
the Modbus message. Some host communication software requires ModBus 
Holding Registers in the form 4xxxx or 3xxxx. With this scheme, what is referred to 
as 'Holding Register 40001' is addressed within the message protocol as register 
address 0000 (not 0001 or 40001). It is very important to ascertain exactly what 
convention the host software uses. 
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Example request to retrieve holding register 100 (set up to contain the raw value 
from channel 1) from node address 6: 

  Node Address   06 

  Function   03 

  Starting Address Hi  00 

  Starting Address Lo  64 

  No. of Registers Hi  00 

  No. of Registers Lo  01 

  CRC Hi    c4 
  CRC Lo    62 

Response from RC250: 

  Node Address   06 

  Function   03 

  Byte count   02 
  Raw Value Hi   06 

  Raw Value Lo   2b (in decimal, 1579) 

  CRC Hi    4e 

  CRC Lo    3b 

Example request to retrieve holding register 200-201 (set up to contain the scaled 
values from channels 1 and 2) from node address 6: 

  Node Address   06 

  Function   03 

  Starting Address Hi  00 

  Starting Address Lo  c8 

  No. of Registers Hi  00 

  No. of Registers Lo  02 

Response from RC250: 

  Node Address   06 

  Function   03 

  Byte count   04 (2 readings, so 4 bytes) 

  Raw Value Hi   00 

  Raw Value Lo   e6 (in decimal, 230 - meaning 23.0 degrees) 
  Raw Value Hi   01 

  Raw Value Lo   ed (in decimal, 493 - meaning 49.3 %RH) 

  CRC Hi    ac 

  CRC Lo    d9 
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Raw Reg holding registers, other than pulse counts, contain values less than 65000. 

Numbers starting from 65441 (0xFFA1) are used to represent out of range or fault 
conditions. These numbers are: 

  65441 (0xFFA1) - Raw value is above maximum value of range 

  65442 (0xFFA2) - Raw value is below minimum value of range 

  65444 (0xFFA4) - Sensor is open circuit 

  65531 (0xFFFB) - No Data 

  65532 (0xFFFC) - Dummy 

Scaling Reg holding registers use the scaling factor to represent these same 
conditions. The scaling factor would normally contain a value of 0 to 4. Values from 
240 (0xF0) upwards contain the following error conditions: 

  240 (0xF0) - Scaled value is above the maximum value of range 

  241 (0xF1) - Scaled value is below the minimum value of range 

  242 (0xF2) - Sensor is open circuit 
  243 (0xF3) - No Data 

  244 (0xF4) - Dummy 

Extra information on RC250 ModBus setup 
The following parameters can be read from the RC250 for each channel: 

Raw value  unsigned integer  data received by the RC250 from the 
transmitter 

Scaled value  signed integer  scaled value from the sensor 

Scaling factor  unsigned integer  number of decimal points in the Scaled value 

Battery value  unsigned integer  percentage transmitter battery level (0-100%) 

Nbr Tx  unsigned integer Tx count 

 

Conversion from the Raw value to the scaled value uses the following formula: 

  Scaled value = (Raw * Span / Max Val + Min)*10^-Dp 

  Scaling factor = Dp 

The Min, Span, Max Val and Dp can be found by selecting the appropriate channel 

in the Rx Configuration table and selecting Edit Channel. 
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The Edit RX Channel window is shown below: 

 

 

Serial Data 
Both ModBus and RC250 Serial Interface protocols are implemented on an RS232 
interface. The interface requires no configuration and will automatically respond 
appropriately to either protocol. It is preset to these settings: 

  Baud Rate: 19200 

  Data Bits: 8 

  Stop Bits: 1 

  Parity:  None 
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Product Specification 
Maximum no. Channels 160 

AC supply 100 to 250V AC (Use only Eltek power supply type)  

Power supply type MP12U note inner -ve and outer +ve 

DC input 12VDC Maximum current <150mA 

Battery endurance Up to 72 hours 

Battery charge time Trickle - allow 72 hours to fully charge an exhausted 
battery pack 

Controls Concealed button (power off) 

Freq. UHF (Europe) Default is 434.225Mhz (refer to label on base) 

Rx sensitivity -117dbm (typical) 

Antenna connection SMA socket 

Antenna – standard ¼ wave whip (standard) – Eltek type UHFFlexi/SMA 

Antenna – lightweight 
(optional) 

dipole Indoor/outdoor dipole, lead length 5m 
standard, accessory type LW-ANT/SMA. 

  The maximum recommended lead length is 10m. 

Antenna – compact 
(optional) 

Yagi Lightweight 3 element Yagi, providing up to 6db 
gain, supplied with 5m lead and plug. 

Temperature Range -10 to +55ºC 

Humidity 95% non-condensing 

Environment  Indoor use only IP40 
A secondary enclosure must be employed for outdoor 
use. 

Transmitter types Compatible with all transmitters in GenII range from 
serial number 7000 

Transmitter Interval 1 second to 4 hours 

 

 

TU1114 9/10/23 


